There is currently a delay in newly added items being indexed, causing delays in their ability to be searchable

Incident Report for RevverDocs

Update

File processing is now caught up and functioning as expected.
Posted Jul 02, 2025 - 19:55 MDT

Update

We are continuing to monitor for any further issues.
Posted Jul 02, 2025 - 11:18 MDT

Update

On Tuesday, July 1st one of the pieces of the 3rd party cloud infrastructure that supports our services for processing new files added to Revver failed. As the cloud provider wasn't able to restore it in a timely manner, we shifted these document processing services to new infrastructure. These services are now running properly, but have a backlog of files to process. During the issue, no files or information were ever at any risk. We are simply behind on the supporting processes for new files. This includes running OCR (optical character recognition), extracting embedded text from new files, running Smart Extract AI, and updating our Search index to make these new files searchable. We hope to be able to catch up on this backlog of file processing and be back to normal timeframes for processing new files by the end of the day today (Wednesday, July 2nd).
Posted Jul 02, 2025 - 11:18 MDT

Monitoring

A fix has been implemented and we are monitoring the results
Posted Jul 01, 2025 - 16:35 MDT

Investigating

We are currently investigating this issue
Posted Jul 01, 2025 - 10:55 MDT
This incident affects: Revver (US) (Search).