Inconsistent preview and overall performance issues impacting some users.

Incident Report for RevverDocs

Resolved

This incident has been resolved.
Posted Feb 05, 2026 - 15:22 MST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 05, 2026 - 12:32 MST

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 05, 2026 - 10:09 MST

Investigating

We are currently investigating reports of inconsistent previewing (and overall performance of Revver) experience impacting some users.
Posted Feb 05, 2026 - 08:15 MST
This incident affected: Revver (US) (Application User Interface, File Preview).