Delays in workflows triggered via automation.

Incident Report for RevverDocs

Resolved

This incident has been resolved.
Posted Apr 07, 2026 - 12:07 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 07, 2026 - 11:02 MDT

Update

We are continuing to work on a fix for this issue.
Posted Apr 07, 2026 - 10:34 MDT

Identified

We have identified the cause of the delays in triggering workflows via automation, and a fix is being implemented.
Posted Apr 07, 2026 - 09:37 MDT
This incident affected: Revver (US) (Automation Engine - Email, Scheduling).