Potential delayed automation triggers

Incident Report for RevverDocs

Resolved

We have confirmed that the previous fix was successful and are now closing this issue. Thank you for your patience.
Posted Aug 28, 2026 - 16:46 MDT

Monitoring

A fix has been implemented for this issue and we believe it should now be fully resolved, but we are monitoring the results closely to make sure.
Posted Aug 28, 2026 - 14:23 MDT

Investigating

We have identified the cause of this issue and a fix is being implemented right away.
Posted Aug 28, 2026 - 13:33 MDT
This incident affected: Revver (US) (Automation Engine - Email, Scheduling).