Users experiencing slow response times, inability to log into Revver.

Incident Report for RevverDocs

Resolved

This incident has been resolved.
Posted Jan 22, 2026 - 21:35 MST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 22, 2026 - 15:23 MST

Identified

We have identified some additional issues that are impacting performance, and are working to implement a resolution as soon as possible.
Posted Jan 22, 2026 - 13:17 MST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 22, 2026 - 11:10 MST

Identified

We have identified the cause of users experiencing slow response times, and some users experiencing an inability to log into Revver. We are actively working to implement a solution.
Posted Jan 22, 2026 - 09:12 MST
This incident affected: Revver (US) (Application User Interface).