Some users experiencing issues logging into Revver.
Incident Report for RevverDocs
Resolved
This incident has been resolved.
Posted Jan 07, 2025 - 14:44 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 07, 2025 - 14:14 MST
Identified
We have identified an issue some users are experiencing with a delay on log in (or inability to log in) to Revver, and are working to implement a resolution to this issue as soon as possible.
Posted Jan 07, 2025 - 13:05 MST
This incident affected: Revver (US) (Application User Interface).