Email import issues impacting some users.

Incident Report for RevverDocs

Resolved

This incident has been resolved.
Posted Jul 30, 2026 - 17:03 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 30, 2026 - 13:48 MDT

Investigating

We are investigating an issue in which some users that have email imports set up with a Microsoft account are experiencing errors/failures to connect.
Posted Jul 30, 2026 - 10:58 MDT
This incident affected: Revver (US) (Automation Engine - Email, Scheduling).