Delays in workflows triggered via automation.

Incident Report for RevverDocs

Resolved

This incident has been resolved.
Posted Oct 28, 2025 - 21:31 MDT

Monitoring

We have identified the cause of delays in the generation of workflow instances that are triggered via automation. We are monitoring the current volume closely to confirm it reaches expected levels once more.
Posted Oct 28, 2025 - 16:33 MDT
This incident affected: Revver (US) (Automation Engine - Email, Scheduling).