Some Customers May Have Experienced Performance Issue

Incident Report for RevverDocs

Resolved

This incident has been resolved.
Posted Jan 23, 2026 - 19:48 MST

Monitoring

At some times on Thursday, January 22nd and Friday, January 23rd we have experienced some performance challenges with the Revver web app.  Some customers may have experienced slowness when loading the app or logging in and taking actions.  We have experienced a much higher load than usual impacting our database, but have taken all immediately available actions to scale our infrastructure and manage the load and monitor things closely.  Performance should be back to normal, but we are monitoring closely and also working on long-term enhancements to avoid similar performance issues in the future.  We apologize for any inconvenience you may have experienced and thank you for your patience.
Posted Jan 23, 2026 - 11:07 MST