Users receiving duplicate email notifications regarding uploads.

Incident Report for RevverDocs

Resolved

This incident has been resolved.
Posted Sep 27, 2023 - 14:34 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 27, 2023 - 12:02 MDT

Investigating

We are currently investigating an issue in which users are receiving multiple duplicate email notifications regarding uploads in their account. We are working to resolve this issue as soon as possible.
Posted Sep 27, 2023 - 11:33 MDT
This incident affected: Revver (US) (Automation Engine - Email, Scheduling).